Subscription provisioning fails due to parent subscription is not synchronized with service plan

Article ID: 3965 
Last Review: Oct,6 2008
Author:
Last updated by: system APPLIES TO:
  • Parallels Business Automation - Enterprise, 4.2

Symptoms

Order fails with the following exception is subscription service status history:

Registering domain in external source failed. An attempt to call external for name servers failed. An attempt to call external for name servers failed. PEM error #2000: Subscription sub_id=1084390 has no such resource, 'domain_parking'..      Registering domain in external source for domain #72189 Selecting domain for registration by order item #70474 Creating domain service for order item #70474  Domain status:Prepared.

Cause

Parent subscription lacks some resources presented in service template.

A common issue is: domain subscription provisioning fails if Default DNS plan has been upgraded and customer subscription to this plan is not in sync with plan.

Resolution

Parent subscription can be determined from error message text. For this example it is: 1084390. To prevent this from happening with other domain subscriptions, it is best to synchronize parent subscription service plan with all subscriptions. Synchronization can be done as follows:

1. Go to parent subscription service plan properties.
2. Click Synchronize.
3. Select Instal New Resouces checkbox.
3. Select "Install Immediatly" as synchronization type.
4. Select other options if necessary.
5. Click Synchronize.

If there is sufficient number of subscriptions (over 500, for instance), current PBA session may expire due to timeout in the middle of synchronization. In this case synchronization will still proceed as scheduled, nothing to worry about.

Scheduling Synchronization

If parent service plan has composite resources (both TBA and old), synchronization may take several hours to finish (see approximate time in the table below). Schedule synchronization so that it finishes before daily billing proces - in order to reduce possible system load.

Number of SubscriptionApproximate Time (Hrs)
5000,3
170003-3,5


Note: after synchronization is finished, check several subscriptions if it has succeeded:
1. In subscription properties: click Synchronize; message "All subscription resources are in sync with plan" signifies of success.
2. In BM.log: search for "UpgradeToCurrentPlanVersion" method invocation  and check its result  below.
Keywords: Synchronization, Order Fails, PEM error #2000


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