LDAP server is not responding, database looks corrupted

Article ID: 5476 
Last Review: Oct,6 2008
Author: APPLIES TO:
  • Parallels Automation (PEM)

Symptoms

LDAP server can be started, but it is not listening on port 389 and is not working, slapcat hangs too.

Cause

LDAP back-end database is corrupted.

Resolution

Use slapd_db_recover to recover the database, for example:
[root@psaldap ldap]# slapd_db_recover -v -h /var/lib/ldap
db_recover: Finding last valid log LSN: file: 1 offset 263805
db_recover: Recovery starting from [1][261683]
db_recover: Recovery complete at Thu Jul 17 08:29:23 2008
db_recover: Maximum transaction ID 80000175 Recovery checkpoint [1][264861]


WARNING: Always backup database files before working the database, for standart install files are located in
/var/lib/ldap
Keywords: ldap qmail slapd


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